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Troubleshooting Launcher and Kubernetes:
Verify License Status#

Symptoms#

Important Change

The Spotted Wakerobin release (2022.06.0), renamed the Jobs pane to Background Jobs.

  • When starting a new session, no dialog box appears (or no option to start a new remote session in Kubernetes appears)
  • When attempting to start a new job, the button in the Jobs pane in the RStudio IDE is labeled Start Local Job, instead of Start Launcher Job

Possible cause#

For Workbench, Launcher, and Kubernetes to function properly, your Workbench license should be authorized to use the Launcher functionality.

The following troubleshooting steps will help you check the status of your license and determine if it is authorized to use the Launcher functionality.

Troubleshooting steps#

Run the following command in a terminal to check the status of your license:

Terminal
$ sudo rstudio-server license-manager status

which should return output similar to the following if you have already activated your license:

Posit License Manager 2023.12.1+402.pro1

-- Local license status --

Status: Activated
Product-Key: [LICENSE KEY]
Has-Key: Yes
Has-Trial: No
Enable-Launcher: 1
Users: 100
Sessions: 10
Expiration: 2020-12-31 00:00:00
Days-Left: 243
License-Scope: System

-- Floating license status --

License server not in use.

The output should include a line with Enable-Launcher: 1. If it does not, verify that you've activated the correct license or contact the Posit sales team at sales@rstudio.com for more information.

If you see output similar to:

Posit License Manager 2023.12.1+402.pro1

-- Local license status --

Trial-Type: Verified
Status: Evaluation
Days-Left: 45
License-Scope: System

-- Floating license status --

License server not in use.

then you already have a valid evaluation license and are authorized to configure and use the Launcher functionality during your evaluation period.

Restart services and test#

After you've verified that you have a valid, active license that is authorized to use the Launcher functionality, restart the Workbench and Launcher services:

Terminal
$ sudo rstudio-server restart
$ sudo rstudio-launcher restart

Verify that the services are running and try to start a new session from the Workbench home page.

If the services are still not starting or you are still experiencing errors when starting a new session, then proceed to
Step 5 - Verify that rserver node and Kubernetes cluster's clocks are synced.