Troubleshooting Connection Issues in Workbench Due to HTTP Proxy Changes
A brief description of what’s being troubleshot.
Description
Users behind a proxy server may experience session connection failures due to missing HTTP Proxy configurations after upgrading to 2024.12.0
Error Message
Affected users may see the following error in the logs:
system error 111 (Connection refused) [description: Proxy connection failed, host: example.host.corpThe primary symptom is that users are unable to connect to their Workbench session.
Cause
As of Workbench 2024.12.0, HTTP Proxy variables are supported in rserver and rsession processes. If Workbench environments are behind a proxy server, the NO_PROXY list must be configured to include local addresses for Job Launcher sessions and other internal services.
Solution
To resolve this issue, ensure that local addresses are properly included in the NO_PROXY list.
Edit the environment variables configuration file:
/etc/rstudio/env-vars
no_proxy=localhost,example.host.corp,host.corpRestart the Workbench services:
sudo systemctl restart rstudio-server
sudo systemctl restart rstudio-launcherFor additional details, refer to the Outgoing Proxies section of the Posit Workbench Administration Guide.
Workaround
If users are still encountering issues, an alternative is to use an IP address instead of a fully qualified domain name (FQDN) in the no_proxy configuration.
For example:
no_proxy=10.10.10.5Known Bug
There is an issue where an extra period (.) is appended to subdomains in proxy settings. This has been addressed in the 2024.12.1 patch release.
If you’re still having issues, you can reach out to Support by opening a ticket.